Website Upgrade

Because of this upgrade, you may need to upgrade from an older Operating System and browser to a version capable of supporting an updated Macon-Atlanta State Bank website.


If you are running Microsoft Windows Server 2008 or older, for example, please upgrade your Operating System soon. If you do not upgrade, you will get a connection error when attempting to access our website.


Please let us know if you have any questions about this change, however you will need to update your operating system or browser to meet these standards.